Back to overview
Downtime

Server Issues

May 30 at 10:37pm BST
Affected services
Server

Resolved
May 30 at 11:06pm BST

This incident has been resolved. All services are back to normal.

Updated
May 30 at 11:03pm BST

Memory is reinserted, all services are booting up

Updated
May 30 at 11:00pm BST

Found to be RAM memory slot loose

Created
May 30 at 10:37pm BST

Main server is currently unavailable, investigation in place